What’s Vulnerable › Vulnerabilities
CVE-2026-87966: Easy Appointments 4.0 - 4.0.2.1 - Unauthenticated Arbitrary Appointment Modification and Deletion via IDOR
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-639
Description
The Easy Appointments WordPress plugin before 4.0.2.2 does not perform an ownership or authorization check on its unauthenticated appointment-reservation endpoint before updating an existing appointment identified by a request-supplied id, allowing unauthenticated attackers to overwrite, and through a follow-on cleanup delete, arbitrary appointments.
Affected products
- Easy Appointments: from 4.0 before 4.0.2.2 — fixed in 4.0.2.2
How to fix
Upgrade to a fixed version: Easy Appointments 4.0.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87966 or the next vulnerability affects your stack