What’s Vulnerable › Vulnerabilities
CVE-2026-87971: If-So Dynamic Content 1.4.4 - 1.10.1 - Reflected XSS via 'message' Parameter
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-79
Description
The If-So Dynamic Content WordPress plugin before 1.10.2 does not validate the URL scheme of a request-supplied value before reflecting it into a link on an admin page, allowing attackers to execute arbitrary JavaScript in the browser of a logged-in user who opens a crafted link.
Affected products
- If-So Dynamic Content: from 1.4.4 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: If-So Dynamic Content 1.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87971 or the next vulnerability affects your stack