What’s Vulnerable › Vulnerabilities
CVE-2026-87974: Asaas Gateway for WooCommerce < 2.7.8 - Unauthenticated Order Payment Bypass via Webhook
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-287
Description
The Asaas Gateway for WooCommerce WordPress plugin before 2.7.8 does not properly authenticate its payment webhook, accepting an empty access token in its default configuration and not verifying that the confirmed payment corresponds to the order it marks paid, allowing unauthenticated attackers to mark arbitrary orders as paid.
Affected products
- Asaas Gateway for WooCommerce: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Asaas Gateway for WooCommerce 2.7.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87974 or the next vulnerability affects your stack