What’s Vulnerable › Vulnerabilities
CVE-2026-87981: Paymob for WooCommerce < 4.1.14 - Contributor+ Payment Gateway Configuration Deletion and Modification via Multiple AJAX Actions
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-862
Description
The Paymob for WooCommerce WordPress plugin before 4.1.14 does not perform a capability check on several admin AJAX actions that manage its payment-gateway configuration, allowing users with contributor-level access to delete, wipe, or modify that configuration, including the stored payment credentials.
Affected products
- Paymob for WooCommerce: before 4.1.14 — fixed in 4.1.14
How to fix
Upgrade to a fixed version: Paymob for WooCommerce 4.1.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87981 or the next vulnerability affects your stack