What’s Vulnerable › Vulnerabilities
CVE-2026-88028: Unauthorized document disclosure via query-operator injection in polymorphic relation identifiers in MongoDB integration for Laravel
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-29
- Weakness: CWE-943
Description
Improper neutralization of special elements in data query logic in the polymorphic relation handling of the MongoDB integration for Laravel can cause a caller-supplied relation identifier to be interpreted as a query condition rather than as a literal identifier. An authenticated user who can influence a stored relation identifier may cause an affected application to return a document other than the intended relation target.
Affected products
- MongoDB Laravel MongoDB (PHP): from 1.2.0 before 5.11.0 — fixed in 5.11.0
How to fix
Upgrade to a fixed version: MongoDB Laravel MongoDB (PHP) 5.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88028 or the next vulnerability affects your stack