What’s Vulnerable › Vulnerabilities
CVE-2026-8804: Cleartext Storage of Sensitive Information for Puppet Resource API
- Severity: medium (CVSS 6.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-07-06
- Weakness: CWE-312
Description
Puppet resource_api (shipped in Puppet Core 8.x and Puppet Enterprise 2023.8.x and 2025.x) does not preserve the sensitive flag on parameters defined via the resource-api, causing values such as passwords to be stored in cleartext in the agent's local transaction state cache. Affected versions of the resource_api module include all versions between 1.5.0 - 1.9.1 and 2.0.0 The issue was fixed in puppet resource_api 1.9.2 and 2.0.1 released with Puppet Core 8.20.0 and PE 2023.8.10 & PE 2025.11.0.
Affected products
- Perforce Puppet Core: from 8.11.0 through 8.19.0; from 8.0.0 through 8.10.0
- Puppet Enterprise: from 2023.8.0 through 2023.8.9; from 2025.0.0 through 2025.10.0
References
Get alerted when CVE-2026-8804 or the next vulnerability affects your stack