What’s Vulnerable › Vulnerabilities
CVE-2026-88064: Backstage: Improper input validation in TechDocs MkDocs configuration
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-10-14
- Weakness: CWE-20
Description
Backstage is an open framework for building developer portals. Prior to 1.14.6 and from 1.15.0 until 1.15.4, the @backstage/plugin-techdocs-node package insufficiently validates mkdocs.yml supplied by an authenticated user who can register or modify a TechDocs source. Unsafe Python YAML tags, markdown_extensions names and configuration, theme options, and extra_templates values can reach the documentation generator and cause unintended code execution. The resulting impact is limited to the files, credentials, network access, and other resources available to the TechDocs backend or build container. This issue is fixed in versions 1.14.6 and 1.15.4.
Affected products
- backstage: before 1.14.6; from 1.15.0 before 1.15.4 — fixed in 1.14.6, 1.15.4
- Linuxfoundation Backstage Plugin-Techdocs-Node: before 1.14.6; from 1.15.0 before 1.15.4 — fixed in 1.14.6, 1.15.4
How to fix
Upgrade to a fixed version: backstage 1.14.6, 1.15.4; Linuxfoundation Backstage Plugin-Techdocs-Node 1.14.6, 1.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/017ace52d9b327ededc6704cf17799c875ae0f29
- https://github.com/backstage/backstage/commit/02cd7cdbb18b687446277b5602adaee7f1d53cbb
- https://github.com/backstage/backstage/commit/25125ee727a3de3418a8fa6a9e458cd5b73ecf26
- https://github.com/backstage/backstage/commit/a7d995f11a5d27f0efbdbe8bb6c21b06988c79c9
- https://github.com/backstage/backstage/commit/a900a9953c8f7ad3ba1906d1d257725a9996cc9d
- https://github.com/backstage/backstage/releases/tag/v1.50.5
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-292q-8mf5-h6g3
Get alerted when CVE-2026-88064 or the next vulnerability affects your stack