What’s Vulnerable › Vulnerabilities
CVE-2026-88089: Microsoft SQL Server Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-31
- Weakness: CWE-122
Description
Heap-based buffer overflow in SQL Server allows an authorized attacker to execute code locally.
Affected products
- Microsoft SQL Server 2017 for x64-based Systems (CU31): from 14.0.3006.16 before 14.0.3560.2 — fixed in 14.0.3560.2
- Microsoft SQL Server 2017 (GDR): from 14.0.0 before 14.0.2140.2 — fixed in 14.0.2140.2
- Microsoft SQL Server 2019 for x64-based Systems (CU32): from 15.0.4003.23 before 15.0.4500.2 — fixed in 15.0.4500.2
- Microsoft SQL Server 2019 (GDR): from 15.0.0 before 15.0.2200.2 — fixed in 15.0.2200.2
- Microsoft SQL Server 2022 for x64-based Systems (CU27): from 16.0.4003.1 before 16.0.4305.5 — fixed in 16.0.4305.5
- Microsoft SQL Server 2022 (GDR): from 16.0.0 before 16.0.1210.3 — fixed in 16.0.1210.3
- Microsoft SQL Server 2025 for x64-based Systems (CU9): from 17.0.4006.2 before 17.0.5015.4 — fixed in 17.0.5015.4
- Microsoft SQL Server 2025 for x64-based Systems (GDR): from 17.0.1050.2 before 17.0.1145.4 — fixed in 17.0.1145.4
How to fix
Upgrade to a fixed version: Microsoft SQL Server 2017 for x64-based Systems (CU31) 14.0.3560.2; Microsoft SQL Server 2017 (GDR) 14.0.2140.2; Microsoft SQL Server 2019 for x64-based Systems (CU32) 15.0.4500.2; Microsoft SQL Server 2019 (GDR) 15.0.2200.2; Microsoft SQL Server 2022 for x64-based Systems (CU27) 16.0.4305.5; Microsoft SQL Server 2022 (GDR) 16.0.1210.3; Microsoft SQL Server 2025 for x64-based Systems (CU9) 17.0.5015.4; Microsoft SQL Server 2025 for x64-based Systems (GDR) 17.0.1145.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88089 or the next vulnerability affects your stack