What’s Vulnerable › Vulnerabilities
CVE-2026-8814
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-23
- Weakness: CWE-409
Description
Versions of the package exifreader before 4.39.0 are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) due to decompressing PNG zTXt metadata without enforcing a built-in maximum decompressed output size. When asynchronous parsing is enabled, a crafted PNG file containing a highly compressed zTXt chunk can cause ExifReader to materialize a disproportionately large Comment value in memory.
Affected products
- exifreader: before 4.39.0 — fixed in 4.39.0
How to fix
Upgrade to a fixed version: exifreader 4.39.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/yuki-matsuhashi/cad1a45d936062438b4ab24613c34c55
- https://github.com/mattiasw/ExifReader/commit/5f116128adc19f674902f8bf582bfe7dd0a36375
- https://security.snyk.io/vuln/SNYK-JS-EXIFREADER-16689340
- https://security.snyk.io/vuln/SNYK-JS-EXIFREADER-16689340
Get alerted when CVE-2026-8814 or the next vulnerability affects your stack