What’s Vulnerable › Vulnerabilities
CVE-2026-8825: Elementor < 4.1.4 - Contributor+ Sensitive Information Disclosure via REST API
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-20
- Weakness: CWE-200
Description
The Elementor Website Builder WordPress plugin before 4.1.4 does not properly check user permissions before returning post data through one of its REST endpoints, allowing authenticated users with Contributor-level access and above to retrieve the title, body and metadata of private posts, private pages and drafts authored by other users (including administrators).
Affected products
- Elementor Website Builder: before 4.1.4 — fixed in 4.1.4
How to fix
Upgrade to a fixed version: Elementor Website Builder 4.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8825 or the next vulnerability affects your stack