What’s Vulnerable › Vulnerabilities
CVE-2026-8843: Calling createIndex with certain index types can crash mongod
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-18 · updated 2026-10-26
- Weakness: CWE-617
Description
Creating a "2dsphere_bucket" index on a non-timeseries bucket collection will succeed, but any subsequent attempt to insert a document which triggers updating that index will crash the server. A similar issue occurs when creating "queryable_encrypted_range" indices. This issue affects MongoDB Server v7.0 versions prior to 7.0.32, v8.0 versions prior to 8.0.21 and v8.2 versions prior to 8.2.6
Affected products
- MongoDB: from 7.0.0 before 7.0.32; from 8.0.0 before 8.0.21; from 8.2.0 before 8.2.6 — fixed in 7.0.32, 8.0.21, 8.2.6
How to fix
Upgrade to a fixed version: MongoDB 7.0.32, 8.0.21, 8.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8843 or the next vulnerability affects your stack