What’s Vulnerable › Vulnerabilities
CVE-2026-88765: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-28
- Weakness: CWE-77
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 12.3 to 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 under certain conditions could allow an authenticated user to achieve remote code execution by importing a specially crafted Git project export to overflow the Unicode conversion buffer used in Advanced Search indexing.
Affected products
- GitLab: from 12.3.0 before 19.1.8; from 19.2.0 before 19.2.6; from 19.3.0 before 19.3.2 — fixed in 19.1.8, 19.2.6, 19.3.2
How to fix
Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88765 or the next vulnerability affects your stack