What’s Vulnerable › Vulnerabilities

CVE-2026-88772: Memory overflow vulnerability leading to Remote Code Execution or Denial of Service

Description

Vulnerability in Citrix NetScaler ADC and Citrix NetScaler Gateway. This issue affects ADC: before 14.1-73.37, before 13.1-64.23, before 14.1-73.37 FIPS, and before 13.1.37.279 FIPS and NDcPP; Gateway: before 14.1-73.37 and before 13.1-64.23 leading to Remote Code Execution or Denial of Service

Summary

CVE-2026-88772 is a memory buffer restriction flaw in Citrix NetScaler ADC and Gateway that can lead to remote code execution or denial of service. It affects ADC versions before 14.1-73.37, 13.1-64.23, 14.1-73.37 FIPS, and 13.1.37.279 FIPS/NDcPP, and Gateway versions before 14.1-73.37 and 13.1-64.23. The vulnerability is actively exploited (listed in CISA KEV, SSVC active, EPSS 78.2%). Apply vendor mitigations immediately and upgrade to the fixed versions: ADC 13.1-64.23, 13.1.37.279, or 14.1-73.37; Gateway 13.1-64.23 or 14.1-73.37, following CISA BOD 26-04 guidance.

CVE-2026-88772 هو خلل في تقييد العمليات داخل حدود المخزن المؤقت للذاكرة في Citrix NetScaler ADC وGateway، مما قد يؤدي إلى تنفيذ تعليمات برمجية عن بُعد أو حجب الخدمة. يؤثر على إصدارات ADC قبل 14.1-73.37 و13.1-64.23 و14.1-73.37 FIPS و13.1.37.279 FIPS/NDcPP، وإصدارات Gateway قبل 14.1-73.37 و13.1-64.23. الثغرة مستغلة فعليًا (مدرجة في CISA KEV، SSVC نشط، EPSS 78.2%). طبّق إجراءات التخفيف من البائع فورًا وقم بالترقية إلى الإصدارات المُصلحة: ADC 13.1-64.23 أو 13.1.37.279 أو 14.1-73.37؛ Gateway 13.1-64.23 أو 14.1-73.37، وفقًا لتوجيهات CISA BOD 26-04.

Affected products

How to fix

Upgrade to a fixed version: Citrix NetScaler ADC 13.1-64.23, 14.1-73.37; Citrix Netscaler Application Delivery Controller Fips 13.1.37.279; Citrix Netscaler Application Delivery Controller Ndcpp 13.1.37.279; Citrix NetScaler Gateway 13.1-64.23, 14.1-73.37; NetScaler ADC 14.1-73.37, 13.1-64.23, 14.1-73.37 FIPS, 13.1.37.279 FIPS and NDcPP; NetScaler Gateway 14.1-73.37, 13.1-64.23. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2026-88772 or the next vulnerability affects your stack