What’s Vulnerable › Vulnerabilities

CVE-2026-88777: Memory overflow vulnerability leading to unpredictable or erroneous behavior or Denial of Service

Description

Memory overflow vulnerability vulnerability in Citrix NetScaler ADC and Citrix NetScaler Gateway. This issue affects ADC: before 14.1-73.37, before 13.1-64.23, before 14.1-73.37 FIPS, and before 13.1.37.279 FIPS and NDcPP; Gateway: before 14.1-73.37 and before 13.1-64.23  leading to unpredictable or erroneous behavior or Denial of Service

Summary

CVE-2026-88777 is a critical memory overflow vulnerability in Citrix NetScaler ADC and Citrix NetScaler Gateway that can cause unpredictable behavior or denial of service. It affects ADC versions before 14.1-73.37, before 13.1-64.23, before 14.1-73.37 FIPS, and before 13.1.37.279 FIPS and NDcPP; Gateway versions before 14.1-73.37 and before 13.1-64.23. There is no known exploitation in CISA KEV or SSVC, and EPSS is 0.7%. Apply the fixed versions: ADC 13.1-64.23, 13.1.37.279, or 14.1-73.37; Gateway 13.1-64.23 or 14.1-73.37.

CVE-2026-88777 هو ثغرة تجاوز سعة الذاكرة حرجة في Citrix NetScaler ADC وCitrix NetScaler Gateway، وقد تؤدي إلى سلوك غير متوقع أو خطأ أو حجب الخدمة. تؤثر على إصدارات ADC قبل 14.1-73.37، وقبل 13.1-64.23، وقبل 14.1-73.37 FIPS، وقبل 13.1.37.279 FIPS وNDcPP؛ وإصدارات Gateway قبل 14.1-73.37 وقبل 13.1-64.23. لا يوجد استغلال معروف في CISA KEV أو SSVC، واحتمال الاستغلال خلال 30 يومًا حسب EPSS هو 0.7%. قم بتثبيت الإصدارات المُصلحة: ADC 13.1-64.23 أو 13.1.37.279 أو 14.1-73.37؛ وGateway 13.1-64.23 أو 14.1-73.37.

Affected products

How to fix

Upgrade to a fixed version: Citrix NetScaler ADC 13.1-64.23, 14.1-73.37; Citrix Netscaler Application Delivery Controller Fips 13.1.37.279; Citrix Netscaler Application Delivery Controller Ndcpp 13.1.37.279; Citrix NetScaler Gateway 13.1-64.23, 14.1-73.37; NetScaler ADC 14.1-73.37, 13.1-64.23, 14.1-73.37 FIPS, 13.1.37.279 FIPS and NDcPP; NetScaler Gateway 14.1-73.37, 13.1-64.23. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2026-88777 or the next vulnerability affects your stack