What’s Vulnerable › Vulnerabilities
CVE-2026-88784: Weglot < 6.4.3 - Unauthenticated Stored XSS via Translated Page Link Rewriting
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-79
Description
The Translate WordPress with Weglot 2.0 WordPress plugin before 6.4.3 does not escape the URLs it re-inserts into a page when rewriting links for a translated language, and reverses the encoding that was applied to them beforehand, allowing unauthenticated users to store a payload which executes in the browser of anyone viewing the page in a translated language.
Affected products
- Translate WordPress with Weglot 2.0: before 6.4.3 — fixed in 6.4.3
How to fix
Upgrade to a fixed version: Translate WordPress with Weglot 2.0 6.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88784 or the next vulnerability affects your stack