What’s Vulnerable › Vulnerabilities
CVE-2026-88795: wpShopGermany IT-RECHT KANZLEI < 2.4 - Unauthenticated RCE via Predictable API Token
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-94
Description
The wpShopGermany IT-RECHT KANZLEI WordPress plugin before 2.4 does not generate its API authentication token securely, deriving it from data the requester controls and creating it as a side effect of the check that is supposed to validate it, allowing unauthenticated attackers to predict the token and use the access it grants to write arbitrary files, leading to remote code execution.
Affected products
- wpShopGermany IT-RECHT KANZLEI: from 1.6 before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: wpShopGermany IT-RECHT KANZLEI 2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88795 or the next vulnerability affects your stack