What’s Vulnerable › Vulnerabilities
CVE-2026-88804: Unauthenticated update of public UI settings leading to stored cross-site scripting in Rancher
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-09-29
- Weakness: CWE-79
Description
An unauthenticated update of public UI settings could be used by remote attackers to execute a stored cross-site scripting attack in the Rancher UI, in SUSE Rancher 2.15 before 2.15.2, 2.14 before 2.14.6, 2.13 before 2.13.10, 2.12 before 2.12.14 and 2.11 before 2.11.18.
Affected products
- SUSE Rancher: from 2.15.0 before 2.15.2; from 2.14.0 before 2.14.6; from 2.13.0 before 2.13.10; from 2.12.0 before 2.12.14; from 2.11.0se before 2.11.18 — fixed in 2.11.18, 2.12.14, 2.13.10, 2.14.6, 2.15.2
How to fix
Upgrade to a fixed version: SUSE Rancher 2.11.18, 2.12.14, 2.13.10, 2.14.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88804 or the next vulnerability affects your stack