What’s Vulnerable › Vulnerabilities
CVE-2026-88824: Master Blocks 1.4.1 - 1.4.1.4 - Unauthenticated Stored XSS via White Label Settings
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-19 · updated 2026-09-21
- Weakness: CWE-79
Description
The Master Blocks WordPress plugin before 1.5.0 does not have authorisation on one of its REST routes, allowing unauthenticated users to update its settings, including a value that is output unescaped in the admin area, leading to Stored XSS that executes in the session of any administrator visiting a wp-admin page.
Affected products
- Master Blocks: from 1.4.1 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Master Blocks 1.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88824 or the next vulnerability affects your stack