What’s Vulnerable › Vulnerabilities
CVE-2026-88843: MasterStudy LMS 3.5.29 - < 3.7.50 - Contributor+ LFI via Elementor Courses Categories Widget
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-22
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.50 does not validate one of its display-style settings before using it to build a template path, allowing users with the Contributor role and above to include and execute arbitrary local PHP files on the server. An equivalent path was corrected in an earlier release and this one was not, so the issue persists in versions the earlier advisory reports as fixed.
Affected products
- MasterStudy LMS WordPress Plugin: from 3.5.29 before 3.7.50 — fixed in 3.7.50
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.7.50. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88843 or the next vulnerability affects your stack