What’s Vulnerable › Vulnerabilities
CVE-2026-88849: MasterStudy LMS 3.7.13 - 3.7.54 - Instructor+ Arbitrary User Display Name Update via Student Enrollment
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-863
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.55 does not verify that a user targeted through its student-enrolment feature has any relationship to the requesting instructor, allowing users with the Instructor role to overwrite the first name, last name and public display name of any registered user on the site, including administrators, enabling impersonation and phishing.
Affected products
- MasterStudy LMS WordPress Plugin: from 3.7.13 before 3.7.55 — fixed in 3.7.55
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.7.55. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-88849 or the next vulnerability affects your stack