What’s Vulnerable › Vulnerabilities
CVE-2026-88881: Renovate before 44.11.3 Credential Exfiltration via Link Header
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-29
- Weakness: CWE-601
Description
Renovate, a dependency update tool, follows pagination links supplied by the GitHub server in the HTTP `Link` header when interacting with GitHub.com, GitHub Enterprise Cloud, or GitHub Enterprise Server, and sends the credentials configured for that host to the URL given as the 'next' page. Because the pagination URL is not validated against the host originally contacted, a malicious or compromised GitHub server can return a `Link` header pointing to an attacker-controlled host and cause Renovate to disclose those credentials to it. Exploitation requires that the GitHub server Renovate talks to (as the repository host or as a datasource such as github-releases, github-tags, or git-refs) is already malicious or compromised. The issue is fixed in renovate 44.11.3 (npm and renovate/renovate container images), Mend Renovate CE/EE images and the mend-renovate-ce helm chart 15.4.0, and the mend-renovate-enterprise-edition helm chart 10.4.0. There is no workaround; the pre-existing RENOVATE_X_REBASE_PAGINATION_LINKS option disables the new host check and should only be used with servers that intentionally use different pagination hosts.
Affected products
- mend-renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend-renovate-enterprise-edition: before 10.4.0 — fixed in 10.4.0
- mend renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-server: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-worker: before 15.4.0 — fixed in 15.4.0
- renovatebot renovate: before 44.11.3 — fixed in 44.11.3
How to fix
Upgrade to a fixed version: mend-renovate-ce 15.4.0; mend-renovate-enterprise-edition 10.4.0; mend renovate-ce 15.4.0; mend renovate-ee-server 15.4.0; mend renovate-ee-worker 15.4.0; renovatebot renovate 44.11.3. Check the vendor advisory for mitigations.
References
- https://github.com/renovatebot/renovate/security/advisories/GHSA-w57v-h33h-835c
- https://www.vulncheck.com/advisories/renovate-before-44.11.3-credential-exfiltration-via-link-header-2
Get alerted when CVE-2026-88881 or the next vulnerability affects your stack