What’s Vulnerable › Vulnerabilities
CVE-2026-88884: Renovate before 44.3.1 Authentication Bypass via Digest Updates
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-29
- Weakness: CWE-863
Description
Renovate is a dependency update automation tool. In versions before 44.3.1 (and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0), digest updates are not subject to the internal `minimumReleaseAge` (stability age) checks. When a repository configures `minimumReleaseAge` and has dependencies with `updateType=digest` — for example GitHub Actions pinned to a commit SHA with a floating tag, Docker images, Go modules or NuGet packages — Renovate will still open a pull request for a newly published digest, marked only with a pending `renovate/stability-days` status check. A newly published, potentially malicious dependency version can therefore cause a PR to be raised and CI workflows to potentially run before the configured minimum release age has elapsed, which is precisely what the Minimum Release Age control is intended to prevent. The issue is fixed in Renovate 44.3.1; as a workaround, digest updates can be disabled or gated behind `dependencyDashboardApproval`.
Affected products
- mend-renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend-renovate-enterprise-edition: before 10.4.0 — fixed in 10.4.0
- mend renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-server: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-worker: before 15.4.0 — fixed in 15.4.0
- renovatebot renovate: before 44.3.1 — fixed in 44.3.1
How to fix
Upgrade to a fixed version: mend-renovate-ce 15.4.0; mend-renovate-enterprise-edition 10.4.0; mend renovate-ce 15.4.0; mend renovate-ee-server 15.4.0; mend renovate-ee-worker 15.4.0; renovatebot renovate 44.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/renovatebot/renovate/security/advisories/GHSA-g4qr-hw2h-687r
- https://www.vulncheck.com/advisories/renovate-before-44.3.1-authentication-bypass-via-digest-updates
Get alerted when CVE-2026-88884 or the next vulnerability affects your stack