What’s Vulnerable › Vulnerabilities
CVE-2026-88886: Renovate before 44.14.7 Command Injection via gradle-wrapper
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-29
- Weakness: CWE-78
Description
Renovate is a dependency update automation tool. In versions before 44.14.7 (and in Mend Renovate CE/EE distributions before 15.4.0, and the mend-renovate-enterprise-edition Helm chart before 10.4.0), the manager/gradle-wrapper module does not escape the distributionUrl value read from a repository's gradle/wrapper/gradle-wrapper.properties file before invoking the Gradle Wrapper CLI. In self-hosted deployments configured with binarySource=docker and allowedUnsafeExecutions=['gradleWrapper', ...], a repository that supplies a crafted distributionUrl (for example, appending a shell metacharacter and command) can cause arbitrary commands to be executed as the Renovate user when Renovate processes a Gradle Wrapper update. The issue is fixed in Renovate 44.14.7; as a workaround, remove 'gradleWrapper' from allowedUnsafeExecutions.
Affected products
- mend-renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend-renovate-enterprise-edition: before 10.4.0 — fixed in 10.4.0
- mend renovate-ce: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-server: before 15.4.0 — fixed in 15.4.0
- mend renovate-ee-worker: before 15.4.0 — fixed in 15.4.0
- renovatebot renovate: before 44.14.7 — fixed in 44.14.7
How to fix
Upgrade to a fixed version: mend-renovate-ce 15.4.0; mend-renovate-enterprise-edition 10.4.0; mend renovate-ce 15.4.0; mend renovate-ee-server 15.4.0; mend renovate-ee-worker 15.4.0; renovatebot renovate 44.14.7. Check the vendor advisory for mitigations.
References
- https://github.com/renovatebot/renovate/security/advisories/GHSA-7chm-46wx-888m
- https://www.vulncheck.com/advisories/renovate-before-44.14.7-command-injection-via-gradle-wrapper
Get alerted when CVE-2026-88886 or the next vulnerability affects your stack