What’s Vulnerable › Vulnerabilities
CVE-2026-89005: WPeMatico RSS Feed Fetcher < 2.8.26 - Contributor+ Stored XSS via Word to Category
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-79
Description
The WPeMatico RSS Feed Fetcher WordPress plugin before 2.8.26 does not sanitise and escape one of its campaign configuration fields when a certain feature is enabled, which allows users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the session of any higher-privileged user who later views the campaign.
Affected products
- WPeMatico RSS Feed Fetcher: before 2.8.26 — fixed in 2.8.26
How to fix
Upgrade to a fixed version: WPeMatico RSS Feed Fetcher 2.8.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89005 or the next vulnerability affects your stack