What’s Vulnerable › Vulnerabilities
CVE-2026-89006: WPeMatico RSS Feed Fetcher < 2.8.27 - Contributor+ Stored XSS via Feed Import
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-79
Description
The WPeMatico RSS Feed Fetcher WordPress plugin before 2.8.27 does not sanitize imported feed content before storing it as post content, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- WPeMatico RSS Feed Fetcher: before 2.8.27 — fixed in 2.8.27
How to fix
Upgrade to a fixed version: WPeMatico RSS Feed Fetcher 2.8.27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89006 or the next vulnerability affects your stack