What’s Vulnerable › Vulnerabilities
CVE-2026-89027: miniOrange JWT Authentication for WP REST APIs < 4.8.0 Authentication Downgrade
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-306
Description
miniOrange JWT Authentication for WP REST APIs plugin for WordPress before 4.8.0 contains an authentication method downgrade vulnerability that allows unauthenticated attackers to bypass administrator-configured authentication by supplying a specific GET parameter without any capability check or nonce verification. Attackers can force the plugin to use Basic HTTP authentication regardless of configured JWT or API token settings, then exploit distinguishable error codes and the absence of rate limiting to perform unthrottled username enumeration and credential guessing attacks.
Affected products
- miniOrange JWT Authentication for WP REST APIs: before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: miniOrange JWT Authentication for WP REST APIs 4.8.0. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wp-rest-api-authentication/#developers
- https://www.vulncheck.com/advisories/miniorange-jwt-authentication-for-wp-rest-apis-authentication-downgrade
Get alerted when CVE-2026-89027 or the next vulnerability affects your stack