What’s Vulnerable › Vulnerabilities
CVE-2026-89050: Quads Ads Manager for Google AdSense < 3.0.5 - Subscriber+ Ad-Selling Payment Bypass via Unverified Success Return URL
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-13 · updated 2026-09-14
- Weakness: CWE-345
Description
The Quads Ads Manager for Google AdSense WordPress plugin before 3.0.5 does not verify payment completion with the configured payment gateway before marking an ad-selling order as paid, allowing users who can place an order to obtain a paid ad placement without payment.
Affected products
- Quads Ads Manager for Google AdSense: from 3.0.4 before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: Quads Ads Manager for Google AdSense 3.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89050 or the next vulnerability affects your stack