What’s Vulnerable › Vulnerabilities
CVE-2026-89087
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-22
- Weakness: CWE-573
Description
The cstruct package before 6.3.0 for OCaml mishandles indexes.
Affected products
- OCaml cstruct: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: OCaml cstruct 6.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89087 or the next vulnerability affects your stack