What’s Vulnerable › Vulnerabilities
CVE-2026-89151
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-22
- Weakness: CWE-863
Description
Forgejo before 16.0.4 allows use of restricted API tokens for unintended access to the "allow maintainer edit" feature.
Affected products
- Forgejo: from 16.0.0 before 16.0.4; before 15.0.8 — fixed in 15.0.8, 16.0.4
How to fix
Upgrade to a fixed version: Forgejo 15.0.8, 16.0.4. Check the vendor advisory for mitigations.
References
- https://codeberg.org/forgejo/forgejo/milestone/139655
- https://codeberg.org/forgejo/forgejo/src/branch/forgejo/release-notes-published/15.0.8.md
Get alerted when CVE-2026-89151 or the next vulnerability affects your stack