What’s Vulnerable › Vulnerabilities
CVE-2026-89157
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-11 · updated 2026-09-16
- Weakness: CWE-190
Description
PCRE2 before 10.48, on 32-bit platforms, has a pcre2_pattern_convert out-of-bounds write when an attacker can provide a large pattern.
Affected products
- PCRE2: from 10.30 before 10.48; 10.48-rc1 — fixed in 10.48
How to fix
Upgrade to a fixed version: PCRE2 10.48. Check the vendor advisory for mitigations.
References
- https://github.com/PCRE2Project/pcre2/releases/tag/pcre2-10.48
- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-q8g2-wprr-34m9
- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-q8g2-wprr-34m9
Get alerted when CVE-2026-89157 or the next vulnerability affects your stack