What’s Vulnerable › Vulnerabilities
CVE-2026-89158
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-16
- Weakness: CWE-190
Description
PCRE2 before 10.48, on 32-bit platforms, has a pcre2_compile_32 integer overflow and resultant out-of-bounds write.
Affected products
- PCRE2: before 10.48; 10.48-rc1 — fixed in 10.48
How to fix
Upgrade to a fixed version: PCRE2 10.48. Check the vendor advisory for mitigations.
References
- https://github.com/PCRE2Project/pcre2/releases/tag/pcre2-10.48
- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-fmgr-6ggq-9859
Get alerted when CVE-2026-89158 or the next vulnerability affects your stack