What’s Vulnerable › Vulnerabilities
CVE-2026-89190: Robin Image Optimizer < 2.0.8 - Subscriber+ Plugin Settings Disclosure via fy_ajax
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-284
Description
The Robin Image Optimizer WordPress plugin before 2.0.8 does not check the user's capabilities before dispatching one of its bundled admin framework's request handlers, allowing users with a subscriber-level account to render admin-only Robin Image Optimizer WordPress plugin before 2.0.8 pages and disclose the Robin Image Optimizer WordPress plugin before 2.0.8's stored settings.
Affected products
- Robin Image Optimizer: before 2.0.8 — fixed in 2.0.8
How to fix
Upgrade to a fixed version: Robin Image Optimizer 2.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89190 or the next vulnerability affects your stack