What’s Vulnerable › Vulnerabilities
CVE-2026-89238: Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-06
- Weakness: CWE-345
Description
WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality coverage and possible policy bypass. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected products
- Apache Software Foundation Apache WSS4J: before 2.4.4; from 3.0.0 before 3.0.6; from 4.0.0 before 4.0.2 — fixed in 2.4.4, 3.0.6, 4.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache WSS4J 2.4.4, 3.0.6, 4.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/1lv4hpl8kon1ns5txjnhn2m2sh9rl22w
- http://www.openwall.com/lists/oss-security/2026/09/30/11
Get alerted when CVE-2026-89238 or the next vulnerability affects your stack