What’s Vulnerable › Vulnerabilities
CVE-2026-89259: Hugo before v0.165.0 Insufficient Permission Restriction via TailwindCSS
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-24
- Weakness: CWE-250
Description
Hugo is a static site generator. From v0.161.0, Hugo executes Node tools under Node's permission model, but TailwindCSS — included in the default security.exec.allow list — requires a highly permissive configuration (--allow-addons, --allow-child-process, --allow-worker). As a result, the restrictions intended by the fix for GHSA-x597-9fr4-5857 could still be bypassed, allowing a Node tool invoked during a build to read and write files outside the project's working directory. Affected versions are those after v0.43; the issue was fixed in v0.165.0 by removing tailwindcss from the default security.exec.allow list. Users who do not use TailwindCSS, or who only build trusted sites, are not affected. As a workaround, users can define a restrictive security.exec.allow list in hugo.toml.
Affected products
- gohugoio hugo: before 0.165.0 — fixed in 0.165.0
How to fix
Upgrade to a fixed version: gohugoio hugo 0.165.0. Check the vendor advisory for mitigations.
References
- https://github.com/gohugoio/hugo/security/advisories/GHSA-vrm6-x8vp-mv2r
- https://www.vulncheck.com/advisories/hugo-before-0.165.0-insufficient-permission-restriction-via-tailwindcss
Get alerted when CVE-2026-89259 or the next vulnerability affects your stack