What’s Vulnerable › Vulnerabilities
CVE-2026-8927: env-set cross-proxy Digest auth state leak
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-03 · updated 2026-09-15
- Weakness: CWE-294
Description
When reusing a libcurl handle for sequential transfers driven by environment-variable proxy configuration, libcurl fails to clear the proxy authentication state between requests. Specifically, if the initial transfer authenticates against `proxyA` using Digest auth, a subsequent transfer routed through `proxyB` erroneously leaks the `Proxy-Authorization:` header intended solely for `proxyA`.
Affected products
- curl: from 7.12.0 before 8.21.0 — fixed in 8.21.0
How to fix
Upgrade to a fixed version: curl 8.21.0. Check the vendor advisory for mitigations.
References
- https://curl.se/docs/CVE-2026-8927.html
- https://curl.se/docs/CVE-2026-8927.json
- https://hackerone.com/reports/3744543
- https://hackerone.com/reports/3744543
Get alerted when CVE-2026-8927 or the next vulnerability affects your stack