What’s Vulnerable › Vulnerabilities
CVE-2026-89277: CAI Content Credentials | Integer Overflow or Wraparound (CWE-190)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-10-15
- Weakness: CWE-190
Description
CAI Content Credentials is affected by an Integer Overflow or Wraparound vulnerability that could result in an application denial-of-service. An attacker could exploit this vulnerability to crash the application, leading to a denial-of-service condition. Exploitation of this issue requires user interaction in that a victim must visit a maliciously crafted URL or interact with a compromised web page.
Affected products
- Adobe C2Pa: before 0.90.17 — fixed in 0.90.17
- Adobe C2Patool: before 0.27.17 — fixed in 0.27.17
How to fix
Upgrade to a fixed version: Adobe C2Pa 0.90.17; Adobe C2Patool 0.27.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89277 or the next vulnerability affects your stack