What’s Vulnerable › Vulnerabilities
CVE-2026-89411: Paymattic < 4.6.26 - Unauthenticated Payment Bypass via Unbound Stripe PaymentIntent
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-09-28
- Weakness: CWE-345
Description
The Paymattic WordPress plugin from 4.6.20 before 4.6.26 does not verify that a confirmed Stripe payment belongs to the order it is applied to, allowing unauthenticated users to mark an arbitrary pending order as paid by confirming a smaller payment of their own against it.
Affected products
- Paymattic: from 4.6.20 before 4.6.26 — fixed in 4.6.26
How to fix
Upgrade to a fixed version: Paymattic 4.6.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89411 or the next vulnerability affects your stack