What’s Vulnerable › Vulnerabilities

CVE-2026-89419

Description

OpenStack Ironic before 39.0.1 sometimes allows a user to change the maintenance setting on a node via PATCH to /v1/nodes/{ident} - in other words, not using the specific maintenance endpoint.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Ironic 29.1.1, 32.1.1, 35.1.1, 39.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-89419 or the next vulnerability affects your stack