What’s Vulnerable › Vulnerabilities
CVE-2026-89673: nfsd: fix XDR padding calculation in ff_encode_getdeviceinfo
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-10-24
Description
In the Linux kernel, the following vulnerability has been resolved: nfsd: fix XDR padding calculation in ff_encode_getdeviceinfo nfsd4_ff_encode_getdeviceinfo() computes the da_addr_body reservation as 16 + netid_len + addr_len, but the subsequent xdr_encode_opaque() calls emit 8 + round_up(netid_len, 4) + round_up(addr_len, 4) bytes. The mismatch means the declared da_addr_body length exceeds the actual encoded data by 2-8 bytes on every flexfile GETDEVICEINFO reply, leaking stale reply-page content to the client and mis-aligning the subsequent version list decode. Use xdr_align_size() for each string length to match what xdr_encode_opaque() actually writes.
Affected products
- Linux kernel: from 5.10.195 before 5.10.270; from 5.15.132 before 5.15.221; from 6.1.53 before 6.1.188; from 4.14.326 before 4.15; from 4.19.295 before 4.20; from 5.4.257 before 5.5 — fixed in 4.15, 4.20, 5.10.270, 5.15.221, 5.5, 6.1.188
How to fix
Upgrade to a fixed version: Linux kernel 4.15, 4.20, 5.10.270, 5.15.221. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/15460c8e6c9bc92cda8f68bc419ac082300ab3d6
- https://git.kernel.org/stable/c/356decf074b82bac5564568203c12426dcea3470
- https://git.kernel.org/stable/c/41ebca28e17f84293650598f86bd69532ec1a8e0
- https://git.kernel.org/stable/c/62e5949f0dd5ec837af144860ff908369df4c7c9
- https://git.kernel.org/stable/c/74015b7be806ad9e21d46f7bd2831df280c6c783
- https://git.kernel.org/stable/c/88bce7e326c368d7df15126ccac537e54bebd467
- https://git.kernel.org/stable/c/8b989aaec85e1293a871d602590c951fe44b8647
- https://git.kernel.org/stable/c/9be67a6be48ddf2ebaa98c0df671690b8f9666e7
Get alerted when CVE-2026-89673 or the next vulnerability affects your stack