What’s Vulnerable › Vulnerabilities
CVE-2026-8981: Lazy Blocks < 4.3.0 - Admin+ Stored XSS via Custom Block Frontend HTML
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-79
Description
The Custom Block Builder WordPress plugin before 4.3.0 does not consistently check the unfiltered_html capability across all paths that write to its block template code fields, allowing administrators on multisite installations (or single-site installs with DISALLOW_UNFILTERED_HTML defined) to inject arbitrary JavaScript that executes for any visitor of pages embedding the affected block.
Affected products
- Custom Block Builder: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: Custom Block Builder 4.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8981 or the next vulnerability affects your stack