What’s Vulnerable › Vulnerabilities
CVE-2026-89904: LoongArch: Fix acpi_package_ids[] array overflow
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: LoongArch: Fix acpi_package_ids[] array overflow With LoongArch virt machine, a typical setting is one core per socket, there will max 256 sockets (packages) on one VM. With PPTT acpi table, array acpi_package_ids[] will be overflowed. Here change the array size of acpi_package_ids[] with the max value of MAX_PACKAGES and KVM_MAX_VCPUS.
Affected products
- Linux kernel: from 6.12.101 before 6.12.110; from 6.18.42 before 6.18.51; from 7.1.6 before 7.2; 7.2 — fixed in 6.12.110, 6.18.51, 7.2, 7.3
How to fix
Upgrade to a fixed version: Linux kernel 6.12.110, 6.18.51, 7.2, 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0195e04b1eec8fb00e2db9c5e55655a3f5e76f60
- https://git.kernel.org/stable/c/2a2367d46d7a4ee4122b7a86e57125542dbbe963
- https://git.kernel.org/stable/c/6311b8c471afa33c18adbe4eb16f862936b71ca3
- https://git.kernel.org/stable/c/d3fd094c13c6d0b74f246461ca4cf427d539c8e8
Get alerted when CVE-2026-89904 or the next vulnerability affects your stack