What’s Vulnerable › Vulnerabilities
CVE-2026-9031: Authenticated Denial-of-Service in HTTPD Service in TP-Link Archer A6
- Severity: medium (CVSS 6.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-10-24
- Weakness: CWE-20
Description
An input validation vulnerability exists in the HTTP-WRITEOEM handler due to insufficient validation of user-supplied data before it is processed by internal flash-write handling logic. Successful exploitation may cause httpd process or device to crash, resulting in loss of access to the web interface and a denial-of-service condition.
Affected products
- TP-Link Systems Inc. Archer A6 v4: before V4_1.15.10 Build 260625 Rel.25447 — fixed in V4_1.15.10 Build 260625 Rel.25447
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer A6 v4 V4_1.15.10 Build 260625 Rel.25447. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-a6/v4/#Firmware
- https://www.tp-link.com/en/support/faq/5234/
- https://www.tp-link.com/us/support/download/archer-a6/v4/#Firmware
Get alerted when CVE-2026-9031 or the next vulnerability affects your stack