What’s Vulnerable › Vulnerabilities
CVE-2026-90325: blk-cgroup: skip dying blkg in blkcg_activate_policy()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: blk-cgroup: skip dying blkg in blkcg_activate_policy() When switching IO schedulers on a block device, blkcg_activate_policy() can race with concurrent blkcg deletion, leading to a use-after-free in rcu_accelerate_cbs. T1: T2: blkg_destroy kill(&blkg->refcnt) // blkg->refcnt=1->0 blkg_release // call_rcu(__blkg_release) ... blkg_free_workfn ->pd_free_fn(pd) elv_iosched_store elevator_switch ... iterate blkg list blkg_get(blkg) // blkg->refcnt=0->1 list_del_init(&blkg->q_node) blkg_put(pinned_blkg) // blkg->refcnt=1->0 blkg_release // call_rcu again rcu_accelerate_cbs // uaf Fix this by checking hlist_unhashed(&blkg->blkcg_node) before getting a reference to the blkg. This is the same check used in blkg_destroy() to detect if a blkg has already been destroyed. If the blkg is already unhashed, skip processing it since it's being destroyed.
Affected products
- Linux kernel: from 6.1.16 before 6.1.17; from 6.2.3 before 6.2.4; 6.3 — fixed in 6.1.17, 6.2.4, 7.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.17, 6.2.4, 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/083b58373463a6e5ee60ecb135269348f68ad7df
- https://git.kernel.org/stable/c/1a267295b1ea6a6477963f3fda84adfecd48fcad
- https://git.kernel.org/stable/c/3d8c3da95c75a4d312e272fc7b4076dd3ba9115c
- https://git.kernel.org/stable/c/5e9220389920f33b6a804d50c548cd0cd1b04634
- https://git.kernel.org/stable/c/7337d012ca3fc3a6a2d1c8e2a19c6d97c38b410d
- https://git.kernel.org/stable/c/b5dae1cd0d8368b4338430ff93403df67f0b8bcc
- https://git.kernel.org/stable/c/d8c872901e6459339374e9eea80aa919176c2ccd
Get alerted when CVE-2026-90325 or the next vulnerability affects your stack