What’s Vulnerable › Vulnerabilities

CVE-2026-90439: NGINX ngx_http_v3_module vulnerability

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with OpenSSL versions <= OpenSSL 3.5.0 under certain configurations, a limited heap buffer overflow could happen while processing a TLS handshake. This can happen in a non-deterministic manner that is beyond the attacker's control. This may cause a heap buffer overflow in the NGINX worker process leading to a restart and/or limited data corruption. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or limited data corruption. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected products

How to fix

Upgrade to a fixed version: F5 NGINX Open Source 1.30.5, 1.31.6; F5 NGINX Plus 37.0.6.2, 37.1.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-90439 or the next vulnerability affects your stack