What’s Vulnerable › Vulnerabilities
CVE-2026-90474: MCPHub before 1.0.32 OAuth 2.0 Authentication Bypass
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-23
- Weakness: CWE-287
Description
MCPHub before 1.0.32 contains an authentication bypass vulnerability in its embedded OAuth 2.0 authorization server where client authentication is disabled by default and PKCE enforcement is optional. Attackers who obtain an authorization code through interception can redeem it for access tokens without providing a client secret or PKCE verifier, gaining access to victim accounts and their privileges.
Affected products
- samanhappy mcphub: before 1.0.32 — fixed in 1.0.32
How to fix
Upgrade to a fixed version: samanhappy mcphub 1.0.32. Check the vendor advisory for mitigations.
References
- https://github.com/samanhappy/mcphub/blob/v1.0.31/src/services/oauthServerService.ts#L26-L38
- https://github.com/samanhappy/mcphub/commit/e927620cd1a80e8691213b01eb8cd6ffa1a66e9f
- https://github.com/samanhappy/mcphub/releases/tag/v1.0.32
- https://github.com/samanhappy/mcphub/security/advisories/GHSA-3m7m-37xf-xp9x
- https://www.vulncheck.com/advisories/mcphub-before-1.0.32-oauth-2.0-authentication-bypass
- https://github.com/samanhappy/mcphub/security/advisories/GHSA-3m7m-37xf-xp9x
Get alerted when CVE-2026-90474 or the next vulnerability affects your stack