What’s Vulnerable › Vulnerabilities
CVE-2026-90553: vLLM before 0.28.0 Remote Code Execution via LlavaOnevision2 processor
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-16
- Weakness: CWE-94
Description
vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers can craft a malicious model with arbitrary code in processing_llava_onevision2.py that executes with vLLM process authority even when trust_remote_code is set to False.
Affected products
- vllm-project vllm: before 0.28.0 — fixed in 0.28.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-3c86-2m5g-59q7
- https://www.vulncheck.com/advisories/vllm-before-0.28.0-remote-code-execution-via-llavaonevision2-processor
Get alerted when CVE-2026-90553 or the next vulnerability affects your stack