What’s Vulnerable › Vulnerabilities
CVE-2026-90560: zstd-jni 1.2.0 through 1.5.7-13 Out-of-Bounds Read via ZstdDictDecompress
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-24
- Weakness: CWE-125
Description
zstd-jni versions 1.2.0 through 1.5.7-13 contain an out-of-bounds read vulnerability in the ZstdDictDecompress constructor because offset and length arguments are never validated against the dictionary array bounds. Attackers can supply arbitrary offset or length values to read memory past the end of the supplied array, potentially causing JVM termination.
Affected products
- luben zstd-jni: from 1.2.0 before 1.5.7-14 — fixed in 1.5.7-14
How to fix
Upgrade to a fixed version: luben zstd-jni 1.5.7-14. Check the vendor advisory for mitigations.
References
- https://github.com/luben/zstd-jni
- https://github.com/luben/zstd-jni/blob/v1.2.0/src/main/java/com/github/luben/zstd/ZstdDictDecompress.java#L37
- https://github.com/luben/zstd-jni/blob/v1.5.7-13/src/main/java/com/github/luben/zstd/ZstdDictDecompress.java#L49
- https://github.com/luben/zstd-jni/commit/b74ab242d640c40897e62aab4c744ddfad1f915f
- https://github.com/luben/zstd-jni/issues/405
- https://github.com/luben/zstd-jni/releases/tag/v1.5.7-14
- https://www.vulncheck.com/advisories/zstd-jni-1.2.0-through-1.5.7-13-out-of-bounds-read-via-zstddictdecompress
- https://github.com/luben/zstd-jni/issues/405
Get alerted when CVE-2026-90560 or the next vulnerability affects your stack