What’s Vulnerable › Vulnerabilities
CVE-2026-90580: FlowiseAI Flowise Evaluations Endpoint index.ts axios.post server-side request forgery
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-13 · updated 2026-09-16
- Weakness: CWE-918
Description
A vulnerability was found in FlowiseAI Flowise up to 3.0.2. This vulnerability affects the function axios.post of the file packages/server/src/controllers/evaluations/index.ts of the component Evaluations Endpoint. The manipulation of the argument Host/X-Forwarded-Proto results in server-side request forgery. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.1.3 is able to resolve this issue. The patch is identified as 700137738bcaebefd4709021f6d6b0abcd7df0ac. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.
Affected products
- FlowiseAI Flowise: from 3.0.1 before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/
- https://github.com/FlowiseAI/Flowise/commit/700137738bcaebefd4709021f6d6b0abcd7df0ac
- https://github.com/FlowiseAI/Flowise/issues/6687
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.3
- https://vuldb.com/cve/CVE-2026-90580
- https://vuldb.com/submit/913327
- https://vuldb.com/vuln/403165
- https://vuldb.com/vuln/403165/cti
Get alerted when CVE-2026-90580 or the next vulnerability affects your stack