What’s Vulnerable › Vulnerabilities
CVE-2026-9062: Agile Store Locator < 1.6.9 - Admin+ Arbitrary File Read via Path Traversal
- Severity: low (CVSS 3.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-13 · updated 2026-07-21
- Weakness: CWE-22
Description
The Store Locator WordPress plugin before 1.6.9 does not validate a parameter before using it in a file path, allowing high-privileged users such as administrators to read arbitrary `.php` files from the server, including configuration files that contain database credentials and authentication keys.
Affected products
- Store Locator WordPress: before 1.6.9 — fixed in 1.6.9
How to fix
Upgrade to a fixed version: Store Locator WordPress 1.6.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9062 or the next vulnerability affects your stack