What’s Vulnerable › Vulnerabilities
CVE-2026-9065: Surecart - SQL Injection
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-20 · updated 2026-07-23
- Weakness: CWE-89
Description
SureCart version prior to 4.2.1 are vulnerable to authenticated SQL injection via multiple parameters ('model_name', 'model_id', 'integration_id', 'provider') on the REST API endpoint '/surecart/v1/integrations/{id}'. The root cause is a flawed escaping bypass in the query builder ('wp-query-builder'). Values passed to the 'where()' method are only sanitized via '$wpdb->prepare()' when they do **not** contain a dot ('.') or the WordPress table prefix ('wp_'). By including a dot anywhere in the payload, an attacker completely bypasses the escaping logic and injects arbitrary SQL into the 'WHERE' clause, allowing full UNION-based extraction of the database.
Affected products
- Brainstorm Force SureCart: from O before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: Brainstorm Force SureCart 4.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9065 or the next vulnerability affects your stack